There have been some small changes in our product. Therefore, please click on the different tabs above to look up the corresponding information for your individual product.
For products purchased until February 2022, please click on the tab named "Until February 2022".
For products purchased from February 2022 onwards, please click on the tab named "From February 2022".
Error |
Cause |
Troubleshooting |
No water is coming out. |
Connections of the Seccua BioFilter are mixed up. |
Dismantle the Seccua BioFilter and attach the connections in the right order. See Install the Seccua BioFilter |
Black water is coming out. |
AntiTox contains activated carbon, so like with any natural product, variation in the product quality may also occur. This can cause turbid water. |
Close the shut-off valve of the outlet. Open the flush valve and flush the Seccua BioFilter until clear water comes out. See Flush the Seccua BioFilter before first use. |
Milky-turbid water is coming out. |
Flushing duration for Seccua BioFilter was too short. |
Close the shut-off valve of the outlet. Open the flush valve and flush the Seccua BioFilter until clear water comes out. |
The filtered water smells unpleasant. |
The water in the BioFilter is fouled. |
Flush the BioFilter. See Flush the Seccua BioFilter before first use. |
Capacity of the AntiTox has been used up. |
Replace the AntiTox medium |
If you are unable to resolve the error, please contact our service via
https://support.seccua.com/hc/en-us
Error |
Cause |
Troubleshooting |
(Hardly) no water is coming out. |
Connections of the Seccua BioFilter are mixed up. |
Dismantle the Seccua BioFilter and attach the connections in the right order. See Install the Seccua BioFilter |
Black water is coming out. |
AntiTox contains activated carbon, so like with any natural product, variation in the product quality may also occur. This can cause turbid water. |
Close the shut-off valve of the outlet. Open the flush valve and flush the Seccua BioFilter until clear water comes out. See Flush the Seccua BioFilter before first use. |
Milky-turbid water is coming out. |
Flushing duration for Seccua BioFilter was too short. |
Close the shut-off valve of the outlet. Open the flush valve and flush the Seccua BioFilter until clear water comes out. |
The filtered water smells unpleasant. |
The water in the BioFilter is fouled. |
Flush the BioFilter. See Flush the Seccua BioFilter before first use. |
Capacity of the AntiTox has been used up. |
Replace the AntiTox medium |
If you are unable to resolve the error, please contact our service via